EVO Steering Bypass Kit From GM

Performance modifications, tips & tricks

Moderators: flyingpolarbear, Dev, James B.

Whipped383
Posts: 2104
Joined: Mon Mar 01, 2010 9:12 pm
Location: Salt Lake, 97K1500,ECSB, 383,Whipple,0411,Marine, 03K2500,CCSB,8.1&Allison, Whipple in progress

Post by Whipped383 »

Right, and after looking the spool valve looking part behind it that is shimmed for your pressure relief remains the same. In my case the fitting was the only part I changed from an older pump, same as the kit does. I just opted to use the 96 line instead of that hokey looking thing the GM kit comes with.

It seems to me no matter how EVO is bypassed it results in full pressure all the time.

Whipped383
Posts: 2104
Joined: Mon Mar 01, 2010 9:12 pm
Location: Salt Lake, 97K1500,ECSB, 383,Whipple,0411,Marine, 03K2500,CCSB,8.1&Allison, Whipple in progress

Post by Whipped383 »

Image

That's what I used

Hog
Posts: 5025
Joined: Tue Dec 11, 2001 4:00 pm
Location: 1997 Chev ECSB L31 350 1997 GMC Sierra SLE RCSB, Ontario

Post by Hog »

That part looks familiar.

Doesnt the diameter of the hole in the center of that part affect fluid flow?

On my 1997 ECSB C1500, 100% OEM, except for tires going from a crazy over assisted feel, with some steering off-center darting at about, at about 40mph, with easy over assisted easy 1 finger, stop to stop steering.
I then did the GM EVO Bypass with no other changes.
When turning the steering wheel from stop to stop on the same asphalt surface in front of the garage, it steers with more effort, and while I can still "one finger" it, that same index finger requires some assistance from its neighbouring thumb. It "feels" tighter than with the malfunctioning OEM EVO parts but has the feeling like its providing more assist, than the 1989 rclb C1500, the 1992 rcsb C1500, Ive owned. But is providing the feeling of less assist than the 1998 ECSB K1500 and the 1997 rcsb that was in the fleet. I guess it is important to note, that when I am talking about steering assist "feel" that I am also comparing the EVO trucks (1997+) also at a stop in park on the same surface, as the variable orifice is affected by changing conditions.

Here's a pic of the GM bypass kit showing its wonky tubing affair.
Image

peace
Hog

Whipped383
Posts: 2104
Joined: Mon Mar 01, 2010 9:12 pm
Location: Salt Lake, 97K1500,ECSB, 383,Whipple,0411,Marine, 03K2500,CCSB,8.1&Allison, Whipple in progress

Post by Whipped383 »

Well there's a little spool valve that sits behind it that controls the pressure, iirc JR had discussed that earlier in this thread.

I have never drove a an EVO equipped truck working, bypassed or not working that had a "tight" feel to it or a "centered" feel to it. I think I could maybe be happy if it worked like it was supposed to but the i get in my gmt800 and it has a steering feel that I like

Speeder
Posts: 10763
Joined: Fri Apr 30, 1999 9:12 pm
Location: 2021 Dodge Durango R/T 2WD, 2008 Colorado work beater, 2003 Dodge Dakota pro-touring project

Post by Speeder »

One of the things I always liked about the old 70s cars was the fact that you could do a pinky lock to lock at speed. It's just a matter of getting used to it, but it was so much easier to slip through traffic back then. I mean, when I drive the 'ol Chevelle once a year when I go to Mom's house for Christmas (it stays at her house as I have no garage) it's hard to get used to, but back when I drove such cars full time... thems was the days...

clunkdog
Posts: 2
Joined: Tue Nov 08, 2016 12:11 pm
Location: New York, NY

Do I replace my steering box next, with the 96 version?

Post by clunkdog »

Guys, new to the forum, owner of a 97 K1500 with 150,000+ miles. We don't use it every day any more, but we love this truck.
About a year ago we started having steering problems, and I assumed it was the pump. I ordered and installed the AC Delco pump without the reservoir, requiring the old unit to be dismantled, etc. At the time I did not know what the EVO was, but figured I needed to pull the part from Whipped's pic and install the old EVO to hook everything up.
Ever since this repair the truck has little-to-no assist at low rpms - for example, when slowing to make a a right hand turn with my foot on the brake, the steering gets very hard to turn.
Sitting still at a stop light, the wheel will not turn until I step on the gas. Parking is a difficult two-foot affair. It makes no difference if I unplug the EVO.
Is my problem the steering box? If so, should I just install the 96 and unplug the EVO?
Thanks!

Whipped383
Posts: 2104
Joined: Mon Mar 01, 2010 9:12 pm
Location: Salt Lake, 97K1500,ECSB, 383,Whipple,0411,Marine, 03K2500,CCSB,8.1&Allison, Whipple in progress

Post by Whipped383 »

I would make sure your o ring is in the correct spot on the pressure fitting before you go much farther. I have seen many people install the o ring in the wrong spot and it covers a port on the fitting

clunkdog
Posts: 2
Joined: Tue Nov 08, 2016 12:11 pm
Location: New York, NY

Post by clunkdog »

Thanks, I will check that out!

jcoker
Posts: 1
Joined: Wed Dec 28, 2016 12:29 pm
Location: North Carolina

2002?

Post by jcoker »

This has been a very informative read. I have the same over-assisted steering in my 2002 Yukon XL. Lots of talk about 96, 97, 99, etc., but will the 96 steering pump work on 2002? How about the earlier gearbox, if it comes to that.

Again, very informative read and my thanks to all that contributed.


JC

Post Reply